using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d(?=\d{0,3}[a-z])[a-z\d]{4}\d";
string substitution = @"";
string input = @"6accd76,64c7c8,6777c8
0e4f9a4fdcfb351397b65cdcabcd0673d768cf59";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}