use strict;
my $str = '6accd76,64c7c8,6777c8
0e4f9a4fdcfb351397b65cdcabcd0673d768cf59';
my $regex = qr/\d(?=\d{0,3}[a-z])[a-z\d]{4}\d/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";