# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d(?=\d{0,3}[a-z])[a-z\d]{4}\d"
test_str = ("6accd76,64c7c8,6777c8\n"
"0e4f9a4fdcfb351397b65cdcabcd0673d768cf59")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.