using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a href=""\/Connector\/ConnectorDetails\?connectorId=([0-9a-f]{8}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12})"" title="">\n\n(.*)\n\n.*<\/a>";
string input = @"<a href=""/Connector/ConnectorDetails?connectorId=fdbf9c31-b4ca-4197-b1c4-061f6fd233fd"" title="">
OLD Aurion Employee Connector
</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}