re = /<a href="\/Connector\/ConnectorDetails\?connectorId=([0-9a-f]{8}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12})" title="">\n\n(.*)\n\n.*<\/a>/m
str = '<a href="/Connector/ConnectorDetails?connectorId=fdbf9c31-b4ca-4197-b1c4-061f6fd233fd" title="">
OLD Aurion Employee Connector
</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end