// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<a href="\/Connector\/ConnectorDetails\?connectorId=([0-9a-f]{8}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12})" title="">\n\n(.*)\n\n.*<\/a>"#).unwrap();
let string = "<a href=\"/Connector/ConnectorDetails?connectorId=fdbf9c31-b4ca-4197-b1c4-061f6fd233fd\" title=\"\">
OLD Aurion Employee Connector
</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}