#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)[ ]{2,}\n"
Local $sString = "Mignonne, allons voir si la rose " & @CRLF & _
"Qui ce matin avait déclose " & @CRLF & _
"Sa robe de pourpre au soleil, " & @CRLF & _
"A point perdu cette vesprée, " & @CRLF & _
"Les plis de sa robe pourprée, " & @CRLF & _
"Et son teint au vôtre pareil." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")