re = /[ ]{2,}\n/mx
str = 'Mignonne, allons voir si la rose
Qui ce matin avait déclose
Sa robe de pourpre au soleil,
A point perdu cette vesprée,
Les plis de sa robe pourprée,
Et son teint au vôtre pareil.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end