import re
regex = re.compile(r"""
[ ]{2,}\n
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("Mignonne, allons voir si la rose \n"
"Qui ce matin avait déclose \n"
"Sa robe de pourpre au soleil, \n"
"A point perdu cette vesprée, \n"
"Les plis de sa robe pourprée, \n"
"Et son teint au vôtre pareil.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")