#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^/[^/]+\.[^/]+$"
Local $sString = "/img/i/234515_8QyJor.png" & @CRLF & _
"/img/i/usb-flash-drive.png" & @CRLF & _
"/234515_8QyJor.png" & @CRLF & _
"/usb-flash-drive.png"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")