$re = '~^/[^/]+\.[^/]+$~m';
$str = '/img/i/234515_8QyJor.png
/img/i/usb-flash-drive.png
/234515_8QyJor.png
/usb-flash-drive.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);