re = /^\/[^\/]+\.[^\/]+$/m
str = '/img/i/234515_8QyJor.png
/img/i/usb-flash-drive.png
/234515_8QyJor.png
/usb-flash-drive.png'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end