import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\"'])\\s*(SELECT)(?:\\s+(?:(?!\\1).)*)?\\s+(FROM)(?:\\s+(?:(?!\\1).)*)?\\1(?:[^\\w]|$)";
final String string = " SELECT * FROM tbl -- no match - not in a string\n"
+ " \"SELECT * FROM tbl\" -- matches - in a double-quoted string\n"
+ " 'SELECT * FROM tbl;' -- matches - in a single-quoted string\n"
+ " 'SELECT * FROM it's -- no match - letter after end quote\n"
+ " \"SELECT * FROM tbl' -- no match - quotation marks don't match\n"
+ " 'SELECT * FROM tbl\" -- no match - quotation marks don't match\n"
+ " \"select * from tbl\" -- no match - keywords not upper case\n"
+ " 'Select * From tbl' -- no match - still not all upper case\n"
+ " \"SELECT col1 FROM\" -- matches - even though no table name\n"
+ " ' SELECT col1 FROM ' -- matches - as above with more whitespace\n"
+ " 'SELECT col1, col2 FROM' -- matches - with multiple columns\n"
+ " \"SELECT 'c' FROM 'tbl'\" -- matches - with identifier names quoted\n"
+ " \"SELECT \"c\" FROM\" -- no match - same quotation marks for identifier\n"
+ " \"SELECT * FROM\" \"quoted\" -- matches - with another unmatched quoted string\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}