$re = '/(["\'])\s*(SELECT)(?:\s+(?:(?!\1).)*)?\s+(FROM)(?:\s+(?:(?!\1).)*)?\1(?:[^\w]|$)/m';
$str = ' SELECT * FROM tbl -- no match - not in a string
"SELECT * FROM tbl" -- matches - in a double-quoted string
\'SELECT * FROM tbl;\' -- matches - in a single-quoted string
\'SELECT * FROM it\'s -- no match - letter after end quote
"SELECT * FROM tbl\' -- no match - quotation marks don\'t match
\'SELECT * FROM tbl" -- no match - quotation marks don\'t match
"select * from tbl" -- no match - keywords not upper case
\'Select * From tbl\' -- no match - still not all upper case
"SELECT col1 FROM" -- matches - even though no table name
\' SELECT col1 FROM \' -- matches - as above with more whitespace
\'SELECT col1, col2 FROM\' -- matches - with multiple columns
"SELECT \'c\' FROM \'tbl\'" -- matches - with identifier names quoted
"SELECT "c" FROM" -- no match - same quotation marks for identifier
"SELECT * FROM" "quoted" -- matches - with another unmatched quoted string
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);