# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([\"'])\s*(SELECT)(?:\s+(?:(?!\1).)*)?\s+(FROM)(?:\s+(?:(?!\1).)*)?\1(?:[^\w]|$)"
test_str = (" SELECT * FROM tbl -- no match - not in a string\n"
" \"SELECT * FROM tbl\" -- matches - in a double-quoted string\n"
" 'SELECT * FROM tbl;' -- matches - in a single-quoted string\n"
" 'SELECT * FROM it's -- no match - letter after end quote\n"
" \"SELECT * FROM tbl' -- no match - quotation marks don't match\n"
" 'SELECT * FROM tbl\" -- no match - quotation marks don't match\n"
" \"select * from tbl\" -- no match - keywords not upper case\n"
" 'Select * From tbl' -- no match - still not all upper case\n"
" \"SELECT col1 FROM\" -- matches - even though no table name\n"
" ' SELECT col1 FROM ' -- matches - as above with more whitespace\n"
" 'SELECT col1, col2 FROM' -- matches - with multiple columns\n"
" \"SELECT 'c' FROM 'tbl'\" -- matches - with identifier names quoted\n"
" \"SELECT \"c\" FROM\" -- no match - same quotation marks for identifier\n"
" \"SELECT * FROM\" \"quoted\" -- matches - with another unmatched quoted string\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.