using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^# Static keyword
(?: (static) \s+
)? # Return type
(?: ( (?:[\w\|_\\\\]*\$this[\w\|_\\\\]*) | (?: (?:[\w\|_\\\\]+) # array notation
(?:\[\])* )* ) \s+ )?
# Method name
([\w_]+) # Arguments
(?: \(([^\)]*)\) )? \s* # Description
(.*)
$";
string input = @"persistAsFirstChild($node)";
RegexOptions options = RegexOptions.Singleline | RegexOptions.CultureInvariant | RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}