$re = '/^# Static keyword
(?: (static) \s+
)? # Return type
(?: ( (?:[\w\|_\\\\\\\\]*\$this[\w\|_\\\\\\\\]*) | (?: (?:[\w\|_\\\\\\\\]+) # array notation
(?:\[\])* )* ) \s+ )?
# Method name
([\w_]+) # Arguments
(?: \(([^\)]*)\) )? \s* # Description
(.*)
$/sux';
$str = 'persistAsFirstChild($node)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);