import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^# Static keyword\n"
+ "(?: (static) \\s+\n"
+ ")? # Return type\n"
+ "(?: ( (?:[\\w\\|_\\\\\\\\]*\\$this[\\w\\|_\\\\\\\\]*) | (?: (?:[\\w\\|_\\\\\\\\]+) # array notation\n"
+ " (?:\\[\\])* )* ) \\s+ )?\n"
+ "# Method name\n"
+ "([\\w_]+) # Arguments\n"
+ "(?: \\(([^\\)]*)\\) )? \\s* # Description\n"
+ "(.*)\n"
+ "$";
final String string = "persistAsFirstChild($node)";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.UNICODE_CASE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}