using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:[A-Z]\w*\s*)*\s?)(?=\sInc)";
string input = @"Parent company Test Alphabet Inc. announced";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}