$re = '/((?:[A-Z]\w*\s*)*\s?)(?=\sInc)/';
$str = 'Parent company Test Alphabet Inc. announced';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);