re = /((?:[A-Z]\w*\s*)*\s?)(?=\sInc)/
str = 'Parent company Test Alphabet Inc. announced'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end