import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*)(?=.swp)";
final String string = ".favorite_regexes.txt.swp\n"
+ ".practice.py.swp\n"
+ ".DS_Store\n"
+ "favorite_regexes.txt\n"
+ "practice.py\n"
+ "zippy.py\n\n"
+ "ab\n"
+ "cabc\n"
+ "abd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}