re = /(.*)(?=.swp)/m
str = '.favorite_regexes.txt.swp
.practice.py.swp
.DS_Store
favorite_regexes.txt
practice.py
zippy.py
ab
cabc
abd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end