#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b([0-1]+)\b"
Local $sString = "101"
Local $sSubst = "0$1~010"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)