const regex = /\b([0-1]+)\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b([0-1]+)\\b', 'g')
const str = `101`;
const subst = `0$1~010`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);