using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([0-1]+)\b";
string substitution = @"0$1~010";
string input = @"101";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}