package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[^]]*\] \[INFO\]`)
var str = `[2024-05-19 22:25:53,852] [INFO] [paperless.auth] Login failed for user \`sasas\` from private IP \`192.168.60.1\`.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}