// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[[^]]*\] \[INFO\]").unwrap();
let string = "[2024-05-19 22:25:53,852] [INFO] [paperless.auth] Login failed for user `sasas` from private IP `192.168.60.1`.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}