$re = '/\[[^]]*\] \[INFO\]/m';
$str = '[2024-05-19 22:25:53,852] [INFO] [paperless.auth] Login failed for user `sasas` from private IP `192.168.60.1`.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);