using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\-_0-9a-zA-Z]{20})([0-9a-fA-F]{32})([^\x00]+)";
string input = @"DbfBialvJznkQWYuOrRa0002282500000ef90000020042db60ecmschargedwii";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}