$re = '/([\-_0-9a-zA-Z]{20})([0-9a-fA-F]{32})([^\x00]+)/';
$str = 'DbfBialvJznkQWYuOrRa0002282500000ef90000020042db60ecmschargedwii';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);