const regex = /([\-_0-9a-zA-Z]{20})([0-9a-fA-F]{32})([^\x00]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\-_0-9a-zA-Z]{20})([0-9a-fA-F]{32})([^\\x00]+)', 'g')
const str = `DbfBialvJznkQWYuOrRa0002282500000ef90000020042db60ecmschargedwii`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}