package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<field>[^\|]+)`)
var str = `Math |
Math | Science | Math
English | Math
Science | Science | Science | Science`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}