re = /^(?<field>[^\|]+)/m
str = 'Math |
Math | Science | Math
English | Math
Science | Science | Science | Science'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end