$re = '/^(?<field>[^\|]+)/m';
$str = 'Math |
Math | Science | Math
English | Math
Science | Science | Science | Science';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);