#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(<|^)(.*)@"
Local $sString = "peter@pan.com" & @CRLF & _
"lucky <jack@pot.com>" & @CRLF & _
""William Tell" <billy@tell.com>" & @CRLF & _
""John Rambo, III" <johnny@rambo.com>" & @CRLF & _
""there, might, be, several, commas inside the quotes" <multiple@commas.com>" & @CRLF & _
""yes, this is also a valid email address, can you believe" <yes@this@is@valid.com>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")