import Foundation
let pattern = #"(<|^)(.*)@"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
peter@pan.com
lucky <jack@pot.com>
"William Tell" <billy@tell.com>
"John Rambo, III" <johnny@rambo.com>
"there, might, be, several, commas inside the quotes" <multiple@commas.com>
"yes, this is also a valid email address, can you believe" <yes@this@is@valid.com>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)