$re = '/(<|^)(.*)@/i';
$str = 'peter@pan.com
lucky <jack@pot.com>
"William Tell" <billy@tell.com>
"John Rambo, III" <johnny@rambo.com>
"there, might, be, several, commas inside the quotes" <multiple@commas.com>
"yes, this is also a valid email address, can you believe" <yes@this@is@valid.com>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);