#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:(?:s[0,1][0-9]|downloads)\.upd|(cm\.k))\.kaspersky(?(1)-labs)\.com$"
Local $sString = "s00.upd.kaspersky.com" & @CRLF & _
"s01.upd.kaspersky.com" & @CRLF & _
"s02.upd.kaspersky.com" & @CRLF & _
"s03.upd.kaspersky.com" & @CRLF & _
"s04.upd.kaspersky.com" & @CRLF & _
"s05.upd.kaspersky.com" & @CRLF & _
"s06.upd.kaspersky.com" & @CRLF & _
"s07.upd.kaspersky.com" & @CRLF & _
"s08.upd.kaspersky.com" & @CRLF & _
"s09.upd.kaspersky.com" & @CRLF & _
"s10.upd.kaspersky.com" & @CRLF & _
"s11.upd.kaspersky.com" & @CRLF & _
"s12.upd.kaspersky.com" & @CRLF & _
"s13.upd.kaspersky.com" & @CRLF & _
"s14.upd.kaspersky.com" & @CRLF & _
"s15.upd.kaspersky.com" & @CRLF & _
"s16.upd.kaspersky.com" & @CRLF & _
"s17.upd.kaspersky.com" & @CRLF & _
"s18.upd.kaspersky.com" & @CRLF & _
"s19.upd.kaspersky.com" & @CRLF & _
"downloads.upd.kaspersky.com" & @CRLF & _
"cm.k.kaspersky-labs.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")