import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:s[0,1][0-9]|downloads)\\.upd|(cm\\.k))\\.kaspersky(?(1)-labs)\\.com$";
final String string = "s00.upd.kaspersky.com\n"
+ "s01.upd.kaspersky.com\n"
+ "s02.upd.kaspersky.com\n"
+ "s03.upd.kaspersky.com\n"
+ "s04.upd.kaspersky.com\n"
+ "s05.upd.kaspersky.com\n"
+ "s06.upd.kaspersky.com\n"
+ "s07.upd.kaspersky.com\n"
+ "s08.upd.kaspersky.com\n"
+ "s09.upd.kaspersky.com\n"
+ "s10.upd.kaspersky.com\n"
+ "s11.upd.kaspersky.com\n"
+ "s12.upd.kaspersky.com\n"
+ "s13.upd.kaspersky.com\n"
+ "s14.upd.kaspersky.com\n"
+ "s15.upd.kaspersky.com\n"
+ "s16.upd.kaspersky.com\n"
+ "s17.upd.kaspersky.com\n"
+ "s18.upd.kaspersky.com\n"
+ "s19.upd.kaspersky.com\n"
+ "downloads.upd.kaspersky.com\n"
+ "cm.k.kaspersky-labs.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}