const regex = /^(?:(?:s[0,1][0-9]|downloads)\.upd|(cm\.k))\.kaspersky(?(1)-labs)\.com$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:s[0,1][0-9]|downloads)\\.upd|(cm\\.k))\\.kaspersky(?(1)-labs)\\.com$', 'gmi')
const str = `s00.upd.kaspersky.com
s01.upd.kaspersky.com
s02.upd.kaspersky.com
s03.upd.kaspersky.com
s04.upd.kaspersky.com
s05.upd.kaspersky.com
s06.upd.kaspersky.com
s07.upd.kaspersky.com
s08.upd.kaspersky.com
s09.upd.kaspersky.com
s10.upd.kaspersky.com
s11.upd.kaspersky.com
s12.upd.kaspersky.com
s13.upd.kaspersky.com
s14.upd.kaspersky.com
s15.upd.kaspersky.com
s16.upd.kaspersky.com
s17.upd.kaspersky.com
s18.upd.kaspersky.com
s19.upd.kaspersky.com
downloads.upd.kaspersky.com
cm.k.kaspersky-labs.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}