package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[A-Z]+\b`)
var str = `The lazy LAD was sorry for the debacle
She wept as her FLAXEN hair tumbled down the parapet`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}