re = /\b[A-Z]+\b/m
str = 'The lazy LAD was sorry for the debacle
She wept as her FLAXEN hair tumbled down the parapet'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end