const regex = /^\[?(?:(?:(?:0000:){5}|::)ffff:|fe80:(?:(?:0000:){3}|:))?((?:\w{1,4}[:.]){0,3}\w{1,4}|[\w:.]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\[?(?:(?:(?:0000:){5}|::)ffff:|fe80:(?:(?:0000:){3}|:))?((?:\\w{1,4}[:.]){0,3}\\w{1,4}|[\\w:.]*)', 'gm')
const str = `2600::1
2001:db8:0:0:1:0:0:1
2001:db8:85a3::8a2e:370:7334
[2001:db8:85a3::8a2e:370:7334]
5cc:1d47:39bf:3b52:593d:633e:f045:3ec4
5cc:1d47:39bf:3b52::1
192.168.1.1
0.0.0.0
255.255.255.255
[0000:0000:0000:0000:0000:ffff:255.255.255.255]
::ffff:255.255.255.255
fe80::593d:633e:f045:3ec4
fe80:0000:0000:0000:593d:633e:f045:3ec4
::1
0:0:0:0:0:0:0:1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}