// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\[?(?:(?:(?:0000:){5}|::)ffff:|fe80:(?:(?:0000:){3}|:))?((?:\w{1,4}[:.]){0,3}\w{1,4}|[\w:.]*)").unwrap();
let string = "2600::1
2001:db8:0:0:1:0:0:1
2001:db8:85a3::8a2e:370:7334
[2001:db8:85a3::8a2e:370:7334]
5cc:1d47:39bf:3b52:593d:633e:f045:3ec4
5cc:1d47:39bf:3b52::1
192.168.1.1
0.0.0.0
255.255.255.255
[0000:0000:0000:0000:0000:ffff:255.255.255.255]
::ffff:255.255.255.255
fe80::593d:633e:f045:3ec4
fe80:0000:0000:0000:593d:633e:f045:3ec4
::1
0:0:0:0:0:0:0:1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}