# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\[?(?:(?:(?:0000:){5}|::)ffff:|fe80:(?:(?:0000:){3}|:))?((?:\w{1,4}[:.]){0,3}\w{1,4}|[\w:.]*)"
test_str = ("2600::1\n"
"2001:db8:0:0:1:0:0:1\n"
"2001:db8:85a3::8a2e:370:7334\n"
"[2001:db8:85a3::8a2e:370:7334]\n"
"5cc:1d47:39bf:3b52:593d:633e:f045:3ec4\n"
"5cc:1d47:39bf:3b52::1\n"
"192.168.1.1\n"
"0.0.0.0\n"
"255.255.255.255\n"
"[0000:0000:0000:0000:0000:ffff:255.255.255.255]\n"
"::ffff:255.255.255.255\n"
"fe80::593d:633e:f045:3ec4\n"
"fe80:0000:0000:0000:593d:633e:f045:3ec4\n"
"::1\n"
"0:0:0:0:0:0:0:1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.