const regex = /^<record>((?!<record>)(\s|\S))*<\/record>$/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^<record>((?!<record>)(\\s|\\S))*<\\\/record>$', 's')
const str = `<record>
blah blah
blah
</record>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}