$re = '/^<record>((?!<record>)(\s|\S))*<\/record>$/s';
$str = '<record>
blah blah
blah
</record>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);