re = /^<record>((?!<record>)(\s|\S))*<\/record>$/
str = '<record>
blah blah
blah
</record>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end