using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{10,255}$)(?=.{4,64}@)[A-z0-9]+(?:[.-][A-z0-9]+)*@[A-z0-9]+(?:[.-][A-z0-9]+)*\.[A-z]+$";
string input = @"a-b.de@fn.cdpdodo
-abde@fn.co
_abde@_fn.co
.abde@fn.co
abde_@fn.co
ab_de@_f------n.co
abdسيبe@fn.co
abde@fn.co
ab_nnnn___0---....................-----de@fn.f.co
abde@.fn.f.co
.......abde@fn.f.co
fkb-----kkkabde@fn.f.co
f3.f3.f3.f3.fff3@gmail.com
qowijdoqiwjdoqwi@coeoicmoei.ecpomep.d.docimequo
a23456789a123456789b123456789c123456789d123456789e123456789f1234@ex.com
a23456789a123456789b123456789c123456789d123456789e123456789f12345@ex.com
wijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwijwijdoqiwjdoqwij@coeo444--icmoei.ecpomepocime
wijdoqiwjdoqwij@coeo444--icmoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecpommoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecoei.ecpomepocime
wijdoqiwjdoqwij@coeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmoei.ecpomepocime
wijdoqiwjdoqwij@coeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmeo444--icmoei.ecpomepocimeecpomepocimeecpomepocimeecpomepocimeecpomepocimeecpomepocimeecpomepocime
[\w.-]{2,}\.[A-z]{2,}
^[A-z0-9][\w.-]{0,64}[A-z0-9]@(?:[A-z0-9-]{1,63}\.){1,3}[A-z]{2,63}$";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}